Why don't I see my web page after Publishing?

When you say you don't see your web page, do you mean:

A) you see an older version of your page,
B) there is no web page or
C) the web page is there but it is missing images.

See the solutions below.


A) If you are seeing an older version of your web page see the details here.


B) If there was no web page, first make sure you Published with the 'My Web Host (FTP)' (or 'iHostVM Host') checkbox turned on. Otherwise it will publish to your disk drive.

Next, check to make sure the web page file is actually on your server in the correct location. To do that:

Open the Publisher Window (menu: Publish > Publisher Project) , go to the 'FTP' tab then press the 'Browse' button (the FTP name, password, etc. must be in place first). You will see the files on your server. If you don't see yours you need to Publish to that location.

If you do see the web page file, it may be that you are calling it with the default syntax, that is, 'www.yourserver.com' . Try using the whole file name. i.e. 'www.yourserver.com/yourpage.html'

If that works but you want to use 'www.yourserver.com' you need to find out what your server uses as a default name (usually index.html or default.html) and rename your file to that. You can rename a page in the page name edit box and re-publish or you can just rename the file on your server using the Publisher, Browse option.



C) If you can see a web page but it is empty or you see a red X where the pictures or images should be, this means that your images files have not been moved to the correct location.

Make sure you are using the 'Gather all files' option when publishing (on the Publisher's Pages tab under 'Path Options'). That will move your image files to correct place.

If you are publishing to disk and then using your own FTP program to copy the files to your web server, make sure you copy the sub-folders that contain the images too.

If you are publishing directly to your web server from SiteSpinner, the image files will be transferred when you publish a page. By default, they will be put in sub-folders with names like 'geometry' and 'image'. When you publish, watch the 'Export Progress' window. You should see messages in the File Transfer window that show the web page and images are being moved.

For example:
Transferring file: /wwwroot/index.html
Transferring file: /wwwroot/image/ARROWUP.GIF
Transferring file: /wwwroot/geometry/obj1p2.png

If, after publishing, you see a red X in your browser where an image should be, try right-clicking on the X and selecting 'Proprieties' from the menu. The Properties window that pops up will show you the address (url) where the image should be. This address should correspond with an image in the File Transfer listing.

If it does not correspond, you may not have Gather mode on or you have not left any files on your disk (if you are transferring manually)

If it does correspond, check to make sure that any capital letters in the name match. Otherwise some servers won't find the file. For example "Test.GIF" may not match "test.gif". In general, it is better to use all lower case for your file and object names. Also avoid using spaces, & ,% and other non-standard characters. They can cause problems too.

If all that looks ok, check your web server to see if you can find the files in the location given in the Properties window.

To do that, open the Publisher Window (menu: Publish > Publisher Project) , go to the 'FTP' tab then press the 'Browse' button (the FTP name, password, etc. must be in place first). You will see the files on your server. If you cannot find the image check the above reasons again (e.g. Gather mode, files left behind).


If that does not help, check for more help on missing images here.
Original Post

Add Reply

Likes (0)
×
×
×
×