Why can't I publish to my web host (FTP)?

Why can't I publish to my web host (FTP)?

Note for versions 2.91L and older:

We have been getting reports that people are no longer able to upload their projects with the built in FTP Publisher. Typically they are seeing a repeated message that looks something like this:

Created Web Server directory: '/yourfoldername/'
Error: (12003) Creating directory on Web Server: '/yourfoldername/'

Apparently a Windows update for IE 11 has changed the underlying Windows FTP library in a way that breaks any programs that use it for uploading. (see the bug report here). This is affecting not only SiteSpinner but many other programs.

The simple solution is to update your SiteSpinner or SiteSpinner Pro to version 2.92i or higher (just go to the SiteSpinner menu: 'Help' > 'Check for Updates' and follow the instructions). The new version no longer relies on the Windows FTP library.

Alternatively, you can publish to 'Files on Disk' and then use a 3rd Party FTP program, such as FileZilla, to copy the published files to your web host.


Note for versions 2.92e/2.92g :

Some customers are reporting that they are no longer able to publish after updating to version SSP 2.92e or SS 2.92g.

- unable to connect using a protocol prefix (e.g. ftp://) in front of the Host Name entry.

Our new internet library (as of v.292e) does not accept a prefix of "ftp://" in the ftp tab's 'Host Name' field whereas the old one did. If the prefix is there it will not connect. Both old and new versions accept url's or ip addresses without the protocol prefix.

So, if you are using such a prefix and are unable to connect, just remove the "ftp://" from your host name url or ip address . That is, just use "ftp.myhost.com" by itself instead of "ftp://ftp.myhost.com" or "192.168.1.1" instead of "ftp://192.168.1.1" (without the quotation marks in all cases). We will correct this in a future release.

- unable to connect in 'Automatic' mode in certain cases

Some web host FTP servers are not responding as expected to an FTPS query that is being sent first in 'Automatic' mode and that is causing the connection to fail.

To correct this, go to the Publisher dialog box in the FTP/FTPS tab and change the drop list (next to 'Retry Attempts') from the default 'Automatic' to 'FTP Only'.

Note: these problems have been corrected for version 2.92i and above.


There are a several reasons why the program (SiteSpinner, Web Engine or WebDwarf) may not work when publishing to your web server:

- First, check the basics. If you cannot connect to Internet using any Windows programs (Internet Explorer, Outlook Express etc.) check to make sure the Windows Internet settings have been set up and/or is still set correctly.

To check your Windows Internet settings: go the Control Panel > Internet Options, Connections tab. Then click the Setup button and/or configure the LAN options to match the connection you wish to use. You can also change these setting from the Internet Explorer tools menu.

- If you don't use Internet Explorer or Outlook / Express. Our tools use your Windows Internet connection to FTP to the Internet. If you don't use Internet Explorer or Outlook /Express, you should still have one of those programs on your system. Try running them and see if they will connect. If when you do they say you 'are not online', try selecting the option to 'work online' and then see if you can Publish your Project.

- If you are experiencing an unreliable connection that seems to work partially you may be using a connection that requires 'Passive Mode' ftp. To correct this select the 'Use Passive Mode' check-box on the FTP tab of the Publisher window.

-The most common reason for failure is that you have a 'firewall' turned on that is blocking the transfer. In that case, you must set the firewall to allow the program access to the Internet.

If the firewall is what is causing the problem you may see "Preparing to Connect ..." and then nothing further. Sometimes it will also say "Could Not Connect" and you may see 'The server name or address could not be resolved.' Depending on the firewall, the program may just wait (hang) until the connection is made or it times out.

If you are using Windows XP, please keep in mind that you may have the XP firewall running by default. Also, be sure you are not using a 3rd party firewall and the XP firewall at the same time. That can cause problems.

If you cannot configure your firewall, try turning it off completely and then publishing (turn it back on when you are done).

- If either your FTP host name, user name or password are incorrect, you will not be able to publish.

If you see a 'Last Error' of 'The server name or address could not be resolved' the host name may be incorrect. Make sure you are using the FTP host name which may not be the same as your web address. Check the spelling.

If you see a 'Last Error' of 'The password was not allowed' it could be an incorrect user name or password (since they work as a pair). Check that the spellings are correct and any capital letters are in the right place.

- Another possible problem is an incorrect 'Remote Publish Directory'. The 'Remote Publish Directory' is the folder on your FTP host where you want your files to be sent. If you do not know the correct folder try leaving it blank. The program will then recommend a default setting when you publish. If that does not work, ask your web hosting service for the correct location.

- If none of the above helps, try publishing to a local directory using the 'Copy to Disk' publishing option. If you can do that without problems, a workaround may be to publish locally then using an 3rd party ftp program (Ftp Explorer, for example, is free - see the instructions to set up this up here) upload the pre-built files from your local directory to your web server.
Original Post

Add Reply

Likes (1)
librarian
×
×
×
×